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Captioning Multimedia with Hi-Caption® SE for Use with Macromedia Flash MX 

The Internet has become a widely popular tool for publishing and finding information.  
Increasingly, web designers and developers can use an array of technologies to provide 
information in rich multimedia formats.  Until recently, however, such multimedia presentations 
were not accessible to all Internet users. 

Users with disabilities often rely on third-party solutions, called assistive technologies, to render 
electronic information accessible.  Today there are accessibility standards and guidelines that 
designers and developers can follow to ensure that users of assistive technologies can access their 
web content.  Captions make it possible for users who do not have the ability to hear the audio 
portion of a multimedia presentation to grasp its content.  This tutorial will introduce the reader to 
closed captions and then discuss the creation and use of closed captions with HiSoftware Hi-
Caption® SE for use with Macromedia® Flash™ MX and the Hi-Caption Viewer for Macromedia 
Flash.  To follow this tutorial, you will need HiSoftware Hi-Caption SE for use with Macromedia 
Flash, and Macromedia Flash MX. 

If you do not have a copy of Hi-Caption SE for use with Macromedia Flash you can download an 
evaluation copy from the HiSoftware website: 
http://www.hisoftware.com/hmccflash/index.html

The tutorial uses demo files that can be downloaded from the HiSoftware website: 
http://www.hisoftware.com/hmccflash/mmfcaptut.zip

(These files take up 12.9 MB.  An unzip program such as StuffIt or WinZip is required to extract 
the tutorial files.) 

If you do not have a copy of Macromedia Flash MX you can get an evaluation copy from the 
Macromedia website: http://www.macromedia.com/  

Why Closed Captions 
Closed captions are captioned text that can be turned on or off by the user, allowing flexible and 
accessible delivery of a multimedia project.  Closed captions provide problem-solving capabilities 
and design flexibility with the following advantages: 

 Ability to translate captioned text to different languages (allowing wider distribution) 

 Compliance with a wide range of accessibility guidelines and standards 

 Ability to access a full movie even when technical capabilities or user environment do not 
permit sound 

Hi-Caption® SE for Use with Macromedia Flash MX 

HiSoftware Hi-Caption® SE for use with Macromedia® Flash™ MX is a unique solution that 
allows designers and developers to deliver rich multimedia content that meets accessibility and 
distribution requirements.  The Hi-Caption solution consists of two parts: the Hi-Caption SE 
Captioning System and the Hi-Caption Viewer component for Macromedia Flash. 

Hi-Caption SE is a closed caption generation system that makes it easy for users to create caption 
text for multimedia content.  The system comes complete with the following features: 

 Transcript Import Wizard 

 Transcript creation capabilities 

 Project support allowing for collaboration 
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 Direct viewing of a Macromedia Flash movie allowing for a complete watch, pause, and 
caption solution 

The Hi-Caption Viewer component provides a 100% customizable captioning interface.  One of 
the most important benefits of closed captions is that the developer can easily define the 
characteristics of the captions to complement the presentation.  The Hi-Caption Viewer allows for 
customization of all design elements and permits the designer or developer to define his or her 
own captioning area or to use the default settings.  Additional information about the Hi-Caption 
Viewer component will be provided later in this tutorial. 

Getting Started with Captions 
For this tutorial we will use the sample media files that can be downloaded from the HiSoftware 
website (see the link provided at the top of this tutorial). 

For this tutorial we will use the sample media files that can be downloaded from the HiSoftware 
website (see the link provided at the top of this tutorial). 

This tutorial will present the following information and techniques: 

 How to create a caption file for a simple Macromedia Flash movie using Hi-Caption SE 

 How to modify the Macromedia Flash movie using the Hi-Caption Viewer component to add 
captions 

 Tips on how to use multiple-language captioning 

 A discussion of buffering initial captions 

 Some basic captioning guidelines 

Creating the Caption File for a Macromedia Flash Movie 

The caption file is an XML file that will be usable by the Macromedia Flash Player.  The caption 
file is used to display captions which are synchronized with the movie when it is playing in the 
Macromedia Flash Player. 

The Hi-Caption SE Interface allows the designer or developer to interact with the movie while 
creating the captions.  Before you begin, there are several items to keep in mind: 

 Using individual captions longer than three lines may make your captions less functional. 

 The number of words that can be displayed in the caption area depends on the size of the 
captioning area as defined in Macromedia Flash. 

 You should always spell-check your captions. 

To start Hi-Caption SE and create the caption file, follow the steps below. 
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Starting Hi-Caption SE 
1 From the Windows Start menu, select Start > Programs > HiSoftware Hi-Caption > Hi-Caption 

SE. 

2 From the File menu, select Open > Select Media File.  In the Open dialog box, select a file 
named dav02-start.swf (or whatever you named your file if you are not following the tutorial 
exactly).  This is the movie file you created in the previous section.  Pictured below is the Hi-
Caption interface. 
 

 
3 The left portion of the Hi-Caption interface displays a media control, depending on which type 

of media file was opened, while the right side displays a grid where captioning text will be 
added.  (If you opened a Windows Media file or a RealNetworks file, then the corresponding 
control will be displayed in the left pane.) 

4 From the Settings menu, select Available Classes and make sure that ENUSCC is included in 
the list.  If it is not included, click on the Add button and choose enuscc.hmccs from the 
SAMIstyles subfolder of the Hi-Caption installation directory. 

Creating the Captioning File 
1 Play the media file by clicking Player > Play in Hi-Caption or by using the media control 

buttons.  After 5-10 seconds or so, pause the file by clicking Player > Stop or by using the 
media control buttons. 

2 After you have stopped the media file, click Add SYNC.  Hi-Caption SE will add the time in 
which you first started playing the media file to the first column in the grid. 
Note: This value will be measured in frames; however, if you are using a Windows Media or 
Real Networks file, the time will be in milliseconds. 

3 Select your class from the drop-down menu in the Class column. 

4 Optionally, you can select the speaker from the drop-down menu in the first cell in the Speaker 
column. 
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5 Add the text spoken by the media file into the fourth cell in the first row of the Captions 
column.  Add SYNC inserts the time in which the Macromedia Flash file was last played.  
Since you as the designer do not know what text will be spoken prior to your hearing it, the 
feature works by letting you listen to the text, making a mental note of it, and then when the 
button is pressed, allows you to enter the starting time for that span of text and then type it in. 
Note: If you are fortunate enough to have a transcript of the text in text or Rich Text Format 
(RTF), you can use the Import Wizard found in the Tools menu.  The Import Wizard will load 
all the text into the grid.  Then you can use the Step Current button to set the frame timings, 
while the Macromedia Flash file is played in Hi-Caption. 

6 Play the file again for 5 -10 seconds or so and then pause the file.  Click the Add SYNC button.  
Next, in the Captions field, add the captioning for that portion of the file. 

7 Repeat until the entire media file has been captioned.  Hi-Caption will have data populated in 
the fields, as shown in the picture below. 

8 When done, select File > Save to save the SAMI file. 

9 To review and adjust your captioning times, rewind the Macromedia Flash file to the beginning 
and play it.  Use the Step Current button to add the current time to the grid and then skip to 
the next time sequence. 

10 When you have completed your captioning and are satisfied with the timings, select File > 
Save.  Next, select File > Save as XML.  The Hi-Caption Viewer for Macromedia Flash will 
use the XML file to display captioning in Macromedia Flash.  By default, the XML that is 
generated by Hi-Caption will be in ANSI format.  This format is approximately half the size 
of Unicode format.  If you are using any special characters from other languages in your 
captioning file, then you need to save your XML in Unicode format.  To change the format, 
select or deselect Generate Unicode XML from the Settings menu in Hi-Caption. 

11 Select File > Save Transcript As to save a text transcript of the captioned content.  Print this file 
out for later use. 

Adding the Hi-Caption Viewer to Macromedia Flash 

You now have a Macromedia Flash movie that has a corresponding file with the captions and time 
points that will allow for closed captioning for viewers of the Macromedia Flash movie.  In order 
to use this captioning file in Macromedia Flash you must install the Hi-Caption viewer for use 
with Macromedia Flash (if you have not done so already).  If you have not installed the 
component, follow the simple installation instructions below. 

1 Locate the Hi-Caption Viewer.mxp file located in the extension folder of the HiSoftware Hi-
Caption SE for use with Macromedia Flash installation directory.  On most users’ systems, 
this location will be C:\Program Files\HISC\Hi-Caption SE\extension, but this may vary if a 
different installation path was selected during installation. 

2 After locating the Hi-Caption Viewer.mxp file, double-click it to use the Macromedia 
Extension Manager to load the Hi-Caption Viewer into Macromedia Flash. 

Page 5 June  2003 



Captioning Multimedia with Hi-Caption® SE for Use with Macromedia Flash MX 

 

Adding Captioning to the Macromedia Flash File 

You are now ready to add captioning to the Macromedia Flash movie.  You will be able to control 
the placement, size, and many other properties of your captions.  Follow the steps below to enable 
the Macromedia Flash movie to use the caption file you created in the previous section of this 
tutorial. 

Defining the Properties of Your Captions 
1 With your Macromedia Flash file open, locate the Components panel in Macromedia Flash and 

Hi-Caption from the Component drop-down menu.  Drag the Hi-Caption Viewer from the 
Components view to your stage.  In our example, we dragged an instance of the Hi-Caption 
Viewer to just below the movie file. 
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2 Click on the instance of the Hi-Caption Viewer in your stage to display the component 

properties.  You will now edit the component parameters 

 
3 The first component property to be modified is the Hi-Caption XML File.  Enter the name of 

the XML file that you saved when creating the captioning.  (The default name was 
dva02.xml.) 

Note: If you do not enter a value for this field, the Hi-Caption Viewer will look 
for an XML file with the same name as your Macromedia Flash file but 
with the XML extension.  When you are distributing or testing your final 
Macromedia Flash file, the XML captioning file needs to be in the same 
folder as your Macromedia Flash file 
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4 Change the Show Captions property to TRUE to display the captioning. 
Note: This will help you to set up the design of the captioning area; however, for the final 
creation of the movie you may want to set this to FALSE, thus allowing movie users to enable 
the captions if they wish to see them.  (This is one of the advantages of closed captioning.)  If 
it is set to FALSE, the captioning area does not appear and a user can simply click on the 
"CC" button to display the captions.  Keep in mind that the "CC" button is a toggle button, 
and by design a click can enable or disable the captions. 

5 Change the Show Caption Speaker property to TRUE, because we want to display the speakers 
in our captioning text. 
Note: Remember that some captions do not require a speaker name; therefore, you may not 
want to view the speaker name. 

6 Because the captioning is stored in the accompanying captioning XML file for the Macromedia 
Flash file, the end user’s system will need to download the XML file.  Depending on the size 
of the captioning, this may cause a delay in display.  You have the option of buffering the 
initial captions to compensate for this delay.  In our example here, we will set the Buffer 
Initial Captions property to TRUE.  If you have set Buffer Initial Captions to TRUE, then you 
can buffer up to four starting frames in your captioning presentation. 

7 If you set Buffer Initial Captions to TRUE, you must also do the following: 

a)  Click on the Buffered Start Frame for Language field and enter up to four starting frames 
to display captions from the buffer.  With Buffer Initial Captions set to TRUE, the 
captioning which will be buffered will be associated with frames in the Macromedia Flash 
presentation.  If you imported your movie file at 12 frames/second, for example, then for 
every second that goes by, the Macromedia Flash file moves 12 frames.  In our example 
here, we are entering the values of 1, 89, 111, and 136, based on our four starting frame 
times as displayed in Hi-Caption. 

b) Click in the Buffered Speakers for Language and enter up to four speakers for the 
captioning.  In our example here, we are entering Narrators as the speaker in all four 
instances. 

c) Click in the Buffered Captions for Language and enter up to four blocks of text for the 
captioning. 

8 For the Language Class Identifier, enter ENUSCC as the value.  This is the value of the class 
that was used in the original captioning file in Hi-Caption, omitting the . prior to the name.  
Adding a valid class name to this field is crucial in order for the captioning to appear in 
Macromedia Flash. 
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9 For the Use Default Caption Button, make sure the value is set to TRUE for this tutorial. 

Note: You may want to use a custom closed caption button for your Macromedia Flash 
movie.  If this is the case, set this property to FALSE.  Remember to define the symbol that 
you will be using for your own caption button. 

10 Leave the Caption Control Button field empty, as we are using the default caption button and 
not a custom one.  (If you were using a custom button, you would enter a reference to the 
instance of that symbol in this field and would set the Default Caption Button property to 
FALSE.) 

11 Leave the CC On Button Image and CC Off Button Image fields empty.  Use these fields if you 
wish to display a symbol for the closed captioning button, while the captioning is playing or 
not playing.  To do so, enter the symbol linkage identifier name of the symbol in this field.  
These properties are associated with the default caption button only. 

12 Caption Button X Position and Caption Button Y Position are used to determine where the 
captioning button will appear.  The location of (0,0) is based on the top left corner of where 
the viewer is placed on the Macromedia Flash stage as shown in the crosshairs symbol.  
Positive values for X and Y move the button to the right and down, respectively, while 
negative values move the button position to the left and up, respectively.  In our example here, 
we have left the default position as (0,0).  In the picture below, the Hi-Caption viewer control 
is displayed below the movie file, with the control aligned to the lower left of the movie. 

 
13 Set the Caption Button Foreground Background Color to #000000 and set the Caption Button 

Background Color to #FFFFFF, which will create a white button with black text.  You may 
use other colors if you choose instead of the defaults mentioned here. 
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14 Click in the value column top open the color chooser control where colors can be selected.  
Leave the Caption Button Background Alpha set to 0.  This is a transparency value, where 0 is 
fully transparent and 100 is not transparent. 

 
15 For Use Default Captions Text Box, select TRUE.  If you select FALSE, you will need to 

provide your own dynamic text field in the following property named Captions Text Box. 

16 There are various fields used to set the appearance of the captioning text.  These include 
Captions Text Box, Captions Font Name, Captions Font Size, Captions Font Color, and 
Captions Background Color.  For this example, we will leave these as default.  Alpha 
Captions Background and Background Captions Alpha relate to allowing transparency of the 
background of the captioning text.  Leave these as default in this example.  If you wish to 
have a border around your default captioning box, set Border Caption Text to TRUE. 

17 The height and width as measured in pixels of the captioning area are controlled by the Caption 
Area Height and Caption Area Width fields.  In this example, set them to 60 and 320, 
respectively. 

18 The placement of the captioning text in relation to the top left of the Hi-Caption viewer is 
controlled by the Caption Area X Position and the Caption Area Y Position.  Positive values 
for X and Y move the captioning text to the right and down, respectively, while negative 
values move the captioning text position to the left and up, respectively.  In our example here, 
we have left the default position as (0,22). 

19 When you have finished defining properties, save your project in Macromedia Flash.  Then, 
from the Control menu in Macromedia Flash, select Test Movie.  Test your movie to make 
sure that the captioning appears and that everything works as designed.  When distributing 
your Macromedia Flash file, be sure to include the XML captioning file along with it. 

Tips for Using Multiple Languages 

The Hi-Caption Viewer component for Macromedia Flash MX allows you to switch languages in 
code (on the fly) during the caption display.  This is done by using ActionScript to access the 
SelectedLangStyleName property of the Hi-Caption Viewer Component.  Note that your selection 
for the SelectedLangStyleName property value must be in the language ID List.  If you have not 
set this property, the component will, by default, define the property to be the first item in the list. 

InstanceName.setSelectedLangStyleName( val ); 
 

where: Instance Name is the name of the Hi-Caption Viewer Component assigned by you in the 
instance field and val is equal to a language ID code from the Language ID list. 

Hi-Caption SE allows for the editing and creation of multiple languages for the same captioning 
file.  The following are some important points to keep in mind:  
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 If you are using languages other than English you should save your XML in Unicode format.  
To change the format, select or deselect Generate Unicode XML from the Settings menu in Hi-
Caption. 

 Because the XML file size can affect the speed of the caption display you should use a single 
XML captioning file for each language (although this is not required.)  If you do combine 
multiple languages into a single file, simply call the InstanceName.setXMLFileName( val ); 
function to use ActionScript to change the caption file. 

 We do not recommend using online translation tools to convert to another language; the 
translations are rarely 100% accurate. 

Some Captioning Tips for the Macromedia Flash Designer 

The following are general closed caption guidelines that should be followed.  For more detailed 
information, see Other Resources, below. 

 Captions that are two or more lines should be left-justified. 

 In general, captions should not exceed three lines. 

 Captions should appear at the bottom of the Macromedia Flash movie. 

 Follow standard capitalization and punctuation rules. 

 Italics should be used for emphasized words.  Please review a captioning guidelines document 
for more information on the use of italics. 

 Remember, the Hi-Caption program will allow you to enter HTML Tags and will escape them 
out as necessary when writing the XML Caption File.  For information on which HTML tags 
are available in Macromedia Flash Player visit the Macromedia website: 
http://www.macromedia.com/support/flash/ts/documents/htmltext.htm  

 Emotion and tone should be conveyed with punctuation marks (i.e., use multiple exclamation 
points to indicate strong emotion). 

 Sound effects or offscreen effects should be noted, e.g., “[jet engine roar].” 

 Ensure that the captions are synchronized to the video. 

 It is preferable not to spell out numbers (use 50, not fifty). 

 Use colors thoughtfully with strong contrasts to make the captions easy to read. 

 
 Any captioning credits should appear at the end of the movie. 

Other Resources 

More information on Hi-Caption SE for use with Macromedia Flash: 
http://www.hisoftware.com.  

More information on Macromedia Flash: http://www.macromedia.com/software/flash/

Other HiSoftware products for Accessibility and Content Quality: 
http://www.hisoftware.com/products/products.htm
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About HiSoftware 

HiSoftware Company, the leader in enterprise content quality management solutions, provides 
innovative products that empower quality assurance teams, content developers, website architects, 
and company executives to work collaboratively on their efforts to create and manage corporate 
web standards for accessibility, privacy, searchability, usability, and custom guidelines and 
policies.  HiSoftware’s integrated, full lifecycle solutions dramatically reduce the time required to 
test, manage, and deploy e-business websites. 

HiSoftware works closely with industry leaders and visionaries to provide solutions for today's 
information accessibility, content quality, and search and retrieval needs.  HiSoftware’s customers 
represent Fortune 500 companies and many of the largest e-commerce, government, and 
educational sites in North America and around the world. 

Founded in 1998, HiSoftware Company maintains North American corporate headquarters in 
Concord, New Hampshire.  Further information about HiSoftware can be found online at 
www.hisoftware.com. 

(c) 2003 HiSoftware Incorporated 
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